Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried to install wine through the software center and terminal and I get this error.

chris@ubuntu:~$ sudo apt-get install wine1.5
[sudo] password for chris: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.16-0ubuntu1) but it is not installable
           Recommends: gnome-exe-thumbnailer but it is not going to be installed or
                       kde-runtime but it is not going to be installed
           Recommends: ttf-droid
           Recommends: ttf-mscorefonts-installer but it is not going to be installed
           Recommends: ttf-umefont but it is not going to be installed
           Recommends: ttf-unfonts-core but it is not going to be installed
           Recommends: winbind but it is not going to be installed
           Recommends: winetricks but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
try running sudo apt-get update and see if the problem persists –  jackweirdy Nov 7 '12 at 16:31
    
I tried that, but I'm still getting the same problem. –  user106241 Nov 8 '12 at 15:36
    
How did you install 12.10? Did you upgrade from 12.04 or install onto a new system? –  jackweirdy Nov 8 '12 at 18:14
    
Onto a new system and I have installed the recommended packages from the console. –  user106241 Nov 8 '12 at 22:16
add comment

2 Answers

Having explored the internet and forum pages I have found the following has worked for me:-

Via terminal give the following codes one at a time

sudo dpkg --add-architecture i386

sudo apt-get update

sudo apt-get install wine

The download amounts to some 500 mb but it has worked!

I am running Linux Mint 14 Mate 64 bit.

share|improve this answer
add comment

I have Ubuntu 12.10 64 Bit and there is no need to do anything additional except the installation of the PPA. But first we need to fix your broken packages:

First we do sudo apt-get install -f to fix Broken packages

Then just in case we do sudo apt-get autoremove to do some cleaning.

To test if everything is fixed do sudo apt-get update. If it finishes with no problems then we are done fixing packages. We now proceed to install wine CORRECTLY:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.5

This will download both, the 32 Bit and 64 Bit packages for Wine as seen in the following output:

cyrex@cyrex:~$ sudo aptitude show wine1.5 -v | grep -e Depends
Depends: debconf (>= 0.5) | debconf-2.0, libc6 (>= 2.14), libgettextpo0, wine1.5-i386 (= 1.5.17-0ubuntu4)

At the end it shows wine1.5-i386 and I have already tested Ms-DOS games and Windows XP games (Both 16 Bit and 32 Bit) working in Ubuntu 12.10 64 Bit.

share|improve this answer
add comment

protected by Community Nov 21 '12 at 9:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.