Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 12.04 onto my Samsung NP550P5C Laptop. All went well. The laptop has an NVidia Optimus GT 650M graphics card, so installed the Bumblebee packages, still no problem can get increased framerate via optirun command etc. Laptop resolution is 1366x768 which is fine.

When I am in the office I connect via a VGA cable to a HP 2311x monitor. Ubuntu does not recognize the monitor and therefore only allows the default resolutions (upto 1024x768). I Googled and found instructions of how to use xrandr to force to a resolution by running the following :

xrandr --newmode "1680x1050" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
xrandr --addmode VGA1 1680x1050
xrandr --output VGA1 --mode 1680×1050

This worked fine up until this weekend. I was at home and messing around with midi software so installed some packages such as Rose Garden and vmpk etc (not that this should of had an effect). I come into the office today and running the script had no effect.

If I run the xrandr command I see that the 1680x1050 mode has been added. Then if I run the last command again the screen does change resolution but the display is corrupted :
It seems as if two resolutions are being output at once. The resolution has indeed changed to 1680x1050 and I see the launcher at the left and the notification area top right. But I also have a smaller desktop displayed over the top of this at the current laptop resolution, at the top left with its own notification area and launcher. Both launchers and notification icons work at normal. Plus any windows that open display fine at the 1680x1050 resolution.

Full Screen Image

I also notice that in display settings the mirror screens is not checked. If I check it then the VGA screen just goes back to 1366x768 and looks normal.

Display Settings Image

Can anyone help?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.