Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying for few days to get my GPU working properly on Alienware M14x with GPU NVidia 555M, but I have no luck at all.
After fresh ubuntu install I did follow the guide here NVIDIA Optimus and Ubuntu 12.10 and istalled Bumblebee without problems. Tested glxspheres/optirun glxspheres both working fine. Now I was continuing to install CUDA as is said here How can I get nVidia CUDA or OpenCL working on a laptop with nVidia discrete card/Intel Integrated Graphics? but I'm getting:

Driver:   Not Selected
Toolkit:  Installation Failed. Using unsupported Compiler.
Samples:  Installation Failed. Missing required libraries.

I did not select the driver as I though Bumblebee installed driver already. How should I proceed?
And also at what point is the NVidia driver being installed and how can I try its working? Bumblebee seems to be installing the driver, CUDA wants to do the same, its all a bit confusing really.

Sorry if its lame question, but I would really want to at least get graphic card and second screen working..

Thank you for any help.

share|improve this question
add comment

2 Answers 2

To fix the Toolkit problem, make sure you are using gcc version 4.6. You can sudo apt-get install gcc-4.6 and then

    sudo mv /usr/bin/gcc-4.6 /usr/bin/gcc

(To un-do this afterwards, you can move the other one back). There may be some way to do this with options to the CUDA installer, but I can't figure it out.

To fix the Samples problem, you can put a link to where it is expected:

    sudo ln -s /usr/lib/x86_64-linux-gnu/libglut.so /usr/lib/libglut.so
share|improve this answer
add comment

The flag -override compiler can be used to suppress the error message about the compiler being unsupported.

./cuda_5.0.35_linux_64_ubuntu11.10-1.run  -override compiler

For me, that also got rid of the glut lib error.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.