Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with high temperature of processor while running applications that use all 8 cores of processor with load of close to 100% during the all running time. And the running time for those applications can be sometimes several hours or days...I have DELL XPS 17 laptop with i7 processor that has 8 emulated cores.

For example, if I am using all 8 cores by running some independent treads, the temperature reaches very fast 90(C) degrees and it stays like that. If I reduce the number of independent threads to 4, so only 4 cores are busy, the temperature is reduced to around 80(C) degrees. Just for a reference, average temperature of processor while idle is around 55(C).

Some suggestion how to avoid so high temperatures while using all processing power (100% of all 8 cores)?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I had the same issue with the same OS on the same Machine...

I presume you have the ATI raedon Video Card in there, like i do... And the problem actualy reside in the GPU heating up, not the CPU..

From experience, if you use the Open-source Drivers, you will have a smoother GUI (gnome) but the card tends to over heat. The solution i found, that works for me is to install Jupiter and set the power setting to LOW.

You can alternatively insert a line to some file throught the CLI but i don't rember it. Maybe can someone help with that.. it starts with

echo low > some_config_file.here

On the other side, you can alos install the Proprietary Driver, But ,again, from experience the Gnome-shell desktop become laggy/choppy. (May not be the case with UNITY, i don't know, never used UNITY).

I went from 83+°C to about 60-63°C.

An usefull tools in this case is sensors. You can install it using

sudo apt-get install lm-sensors

and then run it using

sensors

Hope this helps, you and others, cause i've been looking a long time for an adequat solution.

share|improve this answer

My icore5 under full load never ever goes over 60c and this is in a laptop, if its a desktop, it should run even cooler. Check your fans, make sure that your heatsink is properly seated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.