Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ffmpeg to create videos from some png images.

When I work locally on my computer everything works fine, but when I connect to it through ssh I get an error saying that ffmpeg can not find the preset.

I have tried to add ~/.ffmpeg to my .profile file, but that didn't work.

Any idea how I could fix the problem?

share|improve this question
    
FFmpeg does not use text based preset files for libx264 anymore. It accesses that directly now. So you are either using an old ffmpeg, or perhaps trying to use preset files when they are no longer supported. –  LordNeckbeard Nov 7 '12 at 22:56
    
@LordNeckbeard I can't really understand your answer. I use presets and they work just fine when I run the command from my computer. The problem only arise when I try launch the same command when connected remotely through ssh. –  lucacerone Nov 8 '12 at 8:01
    
Since recent ffmpeg no longer uses text file presets you should not be attempting to be using them--unless you're using an old ffmpeg. You should update your question with your ffmpeg command and the complete console output. –  LordNeckbeard Nov 8 '12 at 18:12
    
still can't understand why a command runs fine when launched locally and not when launched remotely though. –  lucacerone Nov 9 '12 at 13:44
    
unfortunately I can't try it now, I will let you know the output of ffmpeg as soon as I have access to the machine! –  lucacerone Nov 9 '12 at 13:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.