Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used lightdm to hide the users at the login prompt of ubuntu and it hid my account. The only one visible is "other" and it doesn't even have a known password. So, I have accessed the terminal and created a guest account and another account without passwords and they are not visible. I am new to using the terminal so I don't know how to write the commands for either:

  1. making all users/accounts visible to the login and/or
  2. making the guest accounts visible, and then once in the GUI change the login settings to see my admin account.

I have no idea of what else I could do, or even how to do it. I would appreciate any help, I'm in a desperate situation because I really need to access my desktop! THANK YOU!!! Any ideas are appreciated!!!

share|improve this question
Hello and welcome to AskUbuntu! While we would love to help you with your issue, your question is probably an exact duplicate. See this question for solution: – Rafał Cieślak Nov 10 '12 at 9:18

You can get the userlist back by doing this:

sudo /usr/lib/lightdm/lightdm-set-defaults --hide-users false

Unfortunately I'm not sure what you're really trying to solve though. When you click on "Other" you should be able to enter your username and password like normal. You won't be able to use sudo or edit lightdm.conf as a guest user. Did you forget your username?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.