Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I tried to follow the steps in https://wiki.ubuntu.com/Nexus7/Installation but I'm stock on the step 4, because when I{m loading the latest image I got this error Downloaded images failed checksum validation

share|improve this question
2  
Download Image again. Make sure NO OTHER DEVICES are plugged in while installation. –  K.K Patel Nov 7 '12 at 6:02
    
Can you also better define 'Step 4'? –  david6 Nov 7 '12 at 8:03

3 Answers 3

Julio,

We had some caching problems with the checksums that should be resolved now by a new version of the installer and some server-side changes. It's possible that's what you were hitting. Please update your copy of the installer and try again. It's also possible that my old answer, below, still applies:

It sounds like the download is failing. Can you go into your Downloads/UbuntuNexus7 directory see what files are there? You should have rootfs.img, boot.img and a checksum. Those are about 700M worth of files and so perhaps your download is timing out before they finish?

The next thing to try is simply deleting everything in Downloads/UbuntuNexus7 and try again. If that still doesn't work we can investigate alternatives.

share|improve this answer

Ubuntu nexus 7 installer

$ cd ~/Downloads&&tar -xvzf UbuntuNexus7.tar.gz
share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Mahesh Nov 12 '12 at 7:16

The problem seems to be the SHA256SUMS file. The checksums match, so all you need to do is open the downloaded SHA256SUMS file in a text editor, and replace all the * characters with space characters, and erase the two entries for files that were not downloaded with the package. That should fix the issue (at least it did for me). Hope that helps!

Source: I ran sha256sum checksums on both files (raring-preinstalled-desktop-armhf+nexus7.bootimg and raring-preinstalled-desktop-armhf+nexus7.img.gz) and they match what's in the file SHA256SUMS, minus the * characters, so I just erased the * characters, and all other lines after the first two. It worked, so it's likely a parsing error in the installer, possibly to do with the * characters, and possibly to do with the lines for checksums for files that were not included in the download.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.