Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a computer in my classroom that's connected to an LG smart TV (that's actually not so smart. I wouldn't recommend buying one.). For the touch interface, the TV wants a resolution of 1920x1080 at 60Hz. However, I can't seem to set the computer to that resolution. The display settings only offer 1024x768 and 640x480.

The computer dual boots with Windows XP, where widescreen options are available in approximately the required size, but the exact resolution -- or even aspect ratio-- isn't available in XP either.

I tried the following command:

xrandr -s 1920x1080 -r 60

The response was:

Size 1920x1080 not found in available modes

Back in the old days, the solution would be to edit xorg.conf. However, since that file no longer exists, and I haven't found up-to-date info, I don't know what else to do. If it helps, this machine will never be connected to a different display, so resolution flexibility isn't important.

Here's the output of lshw:

*-display:0
         description: VGA compatible controller
         product: 4 Series Chipset Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 03
         width: 64 bits
         clock: 33MHz
         capabilities: vga_controller bus_master cap_list rom
         configuration: driver=i915 latency=0
         resources: irq:42 memory:fe800000-febfffff memory:d0000000-dfffffff ioport:ecd8(size=8)
    *-display:1 UNCLAIMED
         description: Display controller
         product: 4 Series Chipset Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2.1
         bus info: pci@0000:00:02.1
         version: 03
         width: 64 bits
         clock: 33MHz

According to the system settings, my graphics driver is unknown and my "experience" is standard.

This is 64-bit Ubuntu 12.04 (Precise)

Note: There are a number of similar questions to this one, but they didn't include any answers that helped me.

Update

After posting this question, I noticed one in the sidebar that I hadn't found through search but which appeared to contain the answer. Based on that question, I created the /etc/X11/xorg.conf file below:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
    Load  "dri2"
    Load  "dbe"
    Load  "dri"
    Load  "record"
    Load  "extmod"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "LG"
    ModelName    "Smart TV"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "DRI"                   # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "Shadow"                # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    DefaultDepth 24
    #SubSection "Display"
    #   Viewport   0 0
    #   Depth     1
    #EndSubSection
    #SubSection "Display"
    #   Viewport   0 0
    #   Depth     4
    #EndSubSection
    #SubSection "Display"
    #   Viewport   0 0
    #   Depth     8
    #EndSubSection
    #SubSection "Display"
    #   Viewport   0 0
    #   Depth     15
    #EndSubSection
    #SubSection "Display"
    #   Viewport   0 0
    #   Depth     16
    #EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes     "1024x768" "1920x1080"
    EndSubSection
EndSection

According to /var/log/Xorg.0.log, my settings aren't being applied. In fact, I wonder if the config file is even being read.

[  1209.083] (**) intel(0): Depth 24, (--) framebuffer bpp 32
[  1209.084] (==) intel(0): RGB weight 888
[  1209.084] (==) intel(0): Default visual is TrueColor
[  1209.084] (II) intel(0): Integrated Graphics Chipset: Intel(R) G41
[  1209.084] (--) intel(0): Chipset: "G41"
[  1209.084] (**) intel(0): Relaxed fencing enabled
[  1209.084] (**) intel(0): Wait on SwapBuffers? enabled
[  1209.084] (**) intel(0): Triple buffering? enabled
[  1209.084] (**) intel(0): Framebuffer tiled
[  1209.084] (**) intel(0): Pixmaps tiled
[  1209.084] (**) intel(0): 3D buffers tiled
[  1209.084] (**) intel(0): SwapBuffers wait enabled
[  1209.084] (==) intel(0): video overlay key set to 0x101fe
[  1209.172] (II) intel(0): Output VGA1 using monitor section Monitor0
[  1209.260] (II) intel(0): EDID for output VGA1
[  1209.260] (II) intel(0): Printing probed modes for output VGA1
[  1209.260] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
[  1209.260] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
[  1209.260] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
[  1209.260] (II) intel(0): Modeline "848x480"x60.0   33.75  848 864 976 1088  480 486 494 517 +hsync +vsync (31.0 kHz)
[  1209.260] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 489 492 525 -hsync -vsync (31.5 kHz)
[  1209.260] (II) intel(0): Output VGA1 connected
[  1209.260] (II) intel(0): Using user preference for initial modes
[  1209.260] (II) intel(0): Output VGA1 using initial mode 1024x768
[  1209.260] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  1209.260] (II) intel(0): Kernel page flipping support detected, enabling
[  1209.260] (==) intel(0): DPI set to (96, 96)
share|improve this question

closed as off-topic by Scott Severance, Eric Carvalho, Aditya, Radu Rădeanu, Avinash Raj May 5 at 15:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, Aditya, Radu Rădeanu, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Voting to close as I no longer have access to the machine in question and would be unable to verify any answers or supply any additional details. –  Scott Severance May 5 at 6:24

Browse other questions tagged or ask your own question.