Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

TL;DR: grub rescue comes up and won't let me even load bios, boot menu, or fire up live cd/usb. Laptop is EUFI capable, with Windows 8 on one partition.

I have a Lenovo Ideapad which just came in packaged with Windows 8. I repartitioned the hard drive, turned off EUFI and fired up Ubuntu live dvd. Then I installed Ubuntu. However, I quickly decided that it was a mistake and decided to reinstall Ubuntu Server edition. I opened up Windows, deleted partition, prepared everything, and then rebooted. Now, however, grub rescue comes up. This is fine because I've had to deal with this pesky little booger other times, but every time I simply fixed it by loading up a live cd and just doing update-grub and a few other things, and voila. However, this time...well, it just won't let me. Before installing Ubuntu for the first time, I simply pressed F2 (or ESC, I'm not sure) to load up the BIOS and changed settings there (turned off UEFI and stuff). Then, restarted and pressed F12 (or F8, again not sure) to load up boot menu to choose Ubuntu live cd. It all worked splendidly the first time. This time though grub rescue comes up and it isn't even allowing me to enter BIOS, boot loader or anything. As soon as I fire up the machine, the "LENOVO" sign comes up and I desperately press any key I can, but it goes straight up to grub rescue. This is especially terrifying because now I can't go back to the BIOS to switch EUFI back on and load my Windows hard drive. Maybe this may be useful, but "ls" on grub rescue outputs:

(hd0)(hd0,gpt7)(hd0,gpt6)(hd0,gpt5)(hd0,gpt4)(hd0,gpt3)(hd0,gpt2)(hd0,gpt1)(hd1)

I have my Ubuntu server ed. USB ready and Ubuntu desktop ed. DVD fired up. But as I said they are both also helpless against the monster that is grub rescue. Help is much appreciated.

share|improve this question
add comment

1 Answer

PROBLEM SOLVED: For Lenovo IdeaPads with EUFI support, loading bios can be tricky. One way that apparently works is by shutting down the computer and then pressing the OneKeyRecovery button (which looks like a upside-down U with an arrow and is located on the top left). That should force the laptop to enter boot manager/bios, etc. I would delete this question since it's not very applicable to a lot of people, but it might happen to someone else with a Lenovo.

The key should look like this

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.