Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed steam for ubuntu , so I tried to launch it and i get this :

~$ steam
Installing breakpad exception handler for appid(steam)/version(1352224866_client)

~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.10
Release:    12.10
Codename:   quantal

~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler XT [AMD Radeon HD 6700M Series] (rev ff)

What is the problem and how to fix it?

share|improve this question
up vote 11 down vote accepted

Install ia32-libs:

sudo apt-get install ia32-libs
share|improve this answer
thank you it works – Star Diamond Nov 7 '12 at 0:18
I have the same issue and when I try installing ia32-libs I get the following problem. You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: ia32-libs : Depends: ia32-libs-multiarch libldap-2.4-2 : Breaks: libldap-2.4-2:i386 (!= 2.4.28-1.1ubuntu4.1) but 2.4.28-1.1ubuntu4.2 is to be installed libldap-2.4-2:i386 : Breaks: libldap-2.4-2 (!= 2.4.28-1.1ubuntu4.2) but 2.4.28-1.1ubuntu4.1 is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). – Zuhaib Nov 8 '12 at 15:00

Steam needs a lot of 32 bit libraries from your system. If any of these are missing, the Steam executable will crash.

On openSUSE you can check what package provides a specific library with the command zypper wp

On Ubuntu there is no such an easy way, but this site explains the process above quite well.

The full list required for starting Steam:

If you want to find out quickly what is missing, run the following command:

strace -E LD_LIBRARY_PATH=/home/USERNAME/Steam/ubuntu12_32/ -e trace=open /home/USERNAME/Steam/ubuntu12_32/steam (replace USERNAME twice with your account name on your Linux)

It will give you an output something like this in one of the last lines:

open("/home/user/Steam/ubuntu12_32/", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

If there is no line after which doesn't mention ENOENT, you will have to search which package provides the shared library ( in this case) according to the tutorial above.

share|improve this answer

On Reddit I saw a solution:

apt-get install libpango1.0-0:i386
apt-get -f install
share|improve this answer
didnt work for me – Star Diamond Nov 6 '12 at 23:47
Have you tried to install other 32-bit as the post suggested? – OrangeTux Nov 6 '12 at 23:51
yes i have ... sudo apt-get install libpango1.0-0:i386 ; sudo apt-get -f install – Star Diamond Nov 6 '12 at 23:54
LANG=C LD_LIBRARY_PATH=${HOME}/Steam/ubuntu12_32 ldd ${HOME}/Steam/ubuntu12_32/* | grep 'not found'

That should give you a list of all the missing libraries; even if you use a language other than English, leave the last part as 'not found'.

The steam executable itself doesn't depend on many, but those it loads at runtime will exit the process cleanly if their dependencies are unsatisfied, giving no output apart from the "exception handler being installed."

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.