Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A week or so ago I tried to add a new package repo that supposedly had a package I wanted. Unfortunately, the information about it was out of date, and I found that it fails to connect to it each time. I'd like to just remove the new repo, but I'm not sure how to do that.

For context, when I update, I get this:

W:Failed to fetch http://ppa.launchpad.net/geod/ppa-geod/ubuntu/dists/precise/main/source/Sources  404  Not Found [IP: 135.214.42.30 8080]
, W:Failed to fetch http://ppa.launchpad.net/geod/ppa-geod/ubuntu/dists/precise/main/binary-amd64/Packages  404  Not Found [IP: 135.214.42.30 8080]
, W:Failed to fetch http://ppa.launchpad.net/geod/ppa-geod/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found [IP: 135.214.42.30 8080]
, E:Some index files failed to download. They have been ignored, or old ones used instead.
share|improve this question

1 Answer 1

up vote 3 down vote accepted

Open a terminal window (ctrl-alt-t) and run

sudo apt-get install ppa-purge

sudo ppa-purge ppa:geod/ppa-geod

That should do the trick.

Alternatively, you can run gksu software-properties-gtk, in the window that opens, select the Other Software Tab, and delete, find the corresponding lines and delete them.

share|improve this answer
    
I should have tried the "alternatively" first. The first fails with a chicken/egg problem. It refuses to remove a repo it can't connect to. Why the heck isn't that dialog available directly from the update-manager gui? Wouldn't that make sense? –  David M. Karr Nov 7 '12 at 18:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.