Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.10 on my Dell inspiron 5720.

sudo lshw -C network says :

 *-network UNCLAIMED     
       description: Network controller
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f1500000-f1507fff

i tried troubleshooting for the same by browsing the forum.. but the debs mentioned are either for amd 64 or i3 32 bit. i checked http://ubuntuforums.org/showthread.php?t=2078800 but it dint help in anyway either. my laptop is an i5 64 bit. i tried the i3 32 bit dev and while installing, it said the package is of bad quality and is not recommended for installation. i installed anyway but it dint make any difference

moreover, i think while trying to install the add-ons for ndisgtk ,it threw error messages for the kernel pack. im losing my mind over this @_@ PS im completely new to linux


Thanks for the response. Unfortunately neither of those two worked out for me. when i tried modprobe nothing really happened after reboot.and i just searched for the proprietary driver and looks like there are none for bcm43142

share|improve this question

3 Answers 3

I had the same problem and have managed to solve it with help on this forum ! I've Ubuntu 12.10 64bit on my Dell Inspiron 5520. My chipset is

$ lspci -vvnn | grep 14e4
08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

download this file: http://jas.gemnetworks.com/debian/pool/main/w/wireless-bcm43142/wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb

sudo apt-get install linux-headers-generic build-essential dkms

navigate to the folder you have saved the downloaded file and run this command.

sudo dpkg -i wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb

hope this helps ! :-)

share|improve this answer

Intel 64 bit processors use the AMD instruction set, so the AMD x86_64 drivers should work fine, assuming you have a 64 bit installation of Ubuntu. Otherwise, i386 should work. I would try the open-source brcmsmac driver (sudo modprobe brcmsmac in terminal then reboot) first and if that doesn't work try the broadcom-wl proprietary driver.

share|improve this answer

I have provided a patched and for DKMS prepared installation package here.

http://forum.ubuntuusers.de/topic/w-lan-acer-4820tg-broadcom-installation-schlae/#post-2865859

share|improve this answer

protected by Community Jan 28 '13 at 20:03

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.