Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The NetworkManager Version 0.9.4.0 from Ubuntu 12.04 doesent support fully functional VPN Connections over IPv6. (see Do any NetworkManager VPN plugins support IPv6? )

On Ubuntu 12.10 with NetworkManager Version 0.9.6.0 I have no Problem.

How can I install the newer version on Ubuntu 12.04?

share|improve this question

1 Answer 1

If possible download the DEB package from Quantal/12.10 and try to install that with Ubuntu Software Center. If there are no problems it will install. It looks like most installations are source based for network manager though.

You can get the source files and install that. There will be a 'how to install' or readme among the files. This does require more than average knowledge; you might need to tinker with settings or be able to understand errors or notices you get along the way. It is not for the faint hearted.


Other options:

Unless you need to stick with 12.04 (it being a LTS) consider updating to 12.10. It is something that will be less hassle then installing from source.

When installing from source you can also try IRC channel #nm at irc.freenode.net. It might even be worth to see if someone can help you get the version from 12.04 fixed.

share|improve this answer
    
I couldn't install the .deb of the latest NM. It has an unresolveable dependency: libnl-3-200 (>= 3.2.7) –  rubo77 Nov 16 '12 at 8:11
    
It that the only one? libnl-3-200 needs libc6 and there are no other dependencies. You might give it a shot and try to install those too. –  Rinzwind Nov 16 '12 at 8:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.