Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed eclipse though the ubuntu software center but I experienced some issues and I wanted to install the official eclipse version.

I downloaded eclipse classic 4.2.1 from here:

Extracted it, but if I double click "eclipse" it doesn't do anything.

Any ideas how I can fix this?

my eclipse.ini looks like this

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar 
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20120522-1813
-showsplash
-vm /usr/lib/jvm/java-7-oracle/bin/java
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
/usr/lib/jvm/java-7-oracle/bin/java
-vmargs
-Xms40m
-Xmx512m

I also deinstalled openJDK and installed jdk7.

share|improve this question
    
The best way to debug the problem is open a terminal, change the directory to where you have eclipse and run it in terminal, using ./eclipse. The output should help to diagnose the problem. –  Salem Nov 6 '12 at 22:54
    
Okay it seems that I have installed ubuntu 32 bit. Doesn't make any sense , the iso that I have hear is named AMD64 but the terminal doesn't lie file /sbin/init /sbin/init: ELF 32-bit LSB shared object I just redownload ubuntu and reinstall it and try again. Thanks! –  Maik Klein Nov 6 '12 at 23:07
add comment

4 Answers

up vote 4 down vote accepted

Specify the jvm in eclipse.ini file.

-vm
/path/to/jdk/bin/java
share|improve this answer
    
I added the path to the vm in the ini (updated my first post). But it still doesn't work for some reason. –  Maik Klein Nov 6 '12 at 17:32
    
The -vm option and its value (the path) must be on separate lines. According to wiki.eclipse.org/Eclipse.ini –  Tarique Nov 6 '12 at 18:49
    
Also The -vm option must occur before the -vmargs option, since everything after -vmargs is passed directly to the JVM –  Tarique Nov 6 '12 at 18:50
    
I updated my .ini file and it still doesnt work. Maybe it is corrupted. I'll try a different version. –  Maik Klein Nov 6 '12 at 19:10
    
I have added this and also check it as executable –  Mohit Sharma Dec 21 '12 at 20:50
add comment

Check the following:

  • Have you changed ownership of the Eclipse directory to your user/group, and did you check file rights? They might be still set to root.
  • Do you have an Ubuntu 64bit system running?
  • Did you install Java (JVM / JDK) - if so, does it conflict with the version requirements?

Some more hints can be found here and in the Eclipse Wiki

share|improve this answer
    
I just extracted the files in my download folder. I have Ubuntu 64bit and Eclipse 4.2.1 64bit. I deinstalled openJDK now and installed JDK7. I still can't run it. Just nothing happens:( –  Maik Klein Nov 6 '12 at 16:11
add comment

Eclipse 4.2.1 seems to be incompatible with version 1.10 of libwebkitgtk-1.0.0

In order to install Eclipse 4.2.1 in Ubuntu 12.10 (64 bits) you need to downgrade libwebkit to 1.8.3.

  1. Download the files described in

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=392967#c8

  2. Install them by doing

    sudo dpkg -i libwebkitgtk-1.0-0_1.8.3-0ubuntu0.12.04.1_amd64.deb libwebkitgtk-1.0-common_1.8.3-0ubuntu0.12.04.1_all.deb libjavascriptcoregtk-1.0-0_1.8.3-0ubuntu0.12.04.1_amd64.deb
    
  3. Then run

    eclipse -clean
    

This worked very well in my case.

share|improve this answer
add comment

I have installed Eclipse through direct download as well as Software Centre but on ubuntu 12.04 LTS they both seem to hang on splash screen unless the ~/workspace directory is deleted.

I found that by clicking on the splash screen and then pressing Enter it launches perfectly fine even without removing the ~/workspace directory!!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.