Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I received an ASUS Xonar U3 USB sound card today and was pleased to find out that using it under Ubuntu 12.10 was as easy as plugging it in and selecting it in the Audio preferences.

However, what annoys me that the whole range of lowest to highest volume seems to be crammed into about 1% of the volume scale. Between about 1 and ~30% you hear absolutely nothing, while increasing the volume by just one step has my earphones blasting at full force. This doesn't happen with the onboard sound of my Thinkpad T420.

Any idea what causes this and how it can be fixed?

share|improve this question
add comment

1 Answer

I have found out that the problem seems to be the fact that the audio driver currently doesn't turn on the sound card's S/PDIF output channel, which allows normal volume control. Unfortunately, this meant I had to boot into Windows and install the ASUS-supplied driver there, which seemed to have persistently enabled S/PDIF on the sound card. Now I just can select "Digital Output (S/PDIF)" in the Ubuntu audio preferences and everything works perfectly.

I have reported a bug in Lauchpad and hope this will be fixed in future Ubuntu versions so that others won't need this workaround.

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1077829

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.