Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I installed recent Ubuntu version in my Acer 5755G laptop, it is over-heating. The laptop is in good condition,it'll not get heat while using windows 7. I think the problem with the graphics card. But as I'm new to Ubuntu i don't know how to solve the problem. So please someone help me.

Laptop Configurations:

  • i5 second Generation

  • 750GB HDD

  • 2GB nVIDIA graphics card

  • 4GB RAM

share|improve this question
is your computer a hybrid graphics solution? You should check to get the correct graphics drivers for the machine, as I would guess that both cards (intel and dedicated) are running. If you are using the open source drivers, you should be able to use vga_switcheroo. What's the output of cat /sys/kernel/debug/vgaswitcheroo/switch? –  onse Nov 6 '12 at 13:47

3 Answers 3

Here's a link!

Try installing jupiter as mentioned in the link.

share|improve this answer
Jupiter might not be enough. –  VedVals Dec 4 '12 at 9:24

NVidia graphics card eats up a lot of power. You need Bumblebee to control power consumption. Installing it helped reduce my core temperatures and increase battery-life to about 3 hours.

share|improve this answer

Turn off the graphics card from BIOS
I am also using ubutnu 14.04LTS. Heating problem is almost all linux os has for those laptop having two graphics (integrated and dedicated like nvidia).
The solution is turn off the graphics card from BIOS setting. This works for me and gives almost 3.5 hours battery backup and no more heating.

Tell me if it works for U.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.