Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

This problem happens sometimes when ubuntu starts up. You can't really boot to the interface sometimes.

Splash Screen with the 5 dots and a message saying:

waiting for network configuration

followed by:

waiting an additional 60 seconds for network configuration

share|improve this question

5 Answers 5

up vote 26 down vote accepted

I decided to go the CLI and Alt+Ctrl+F2 approach so YOU ARE FREE to do that while you are logged in to the GUI - Okay, I will write the general steps so feel free to use whatever approach you like.

  1. Edit /etc/network/interfaces:

    sudo nano /etc/network/interfaces
    

1.1 If you are typing this from LXTerminal while logged in to the GUI then:

gksudo leafpad /etc/network/interfaces
  1. Remove whatever written there and just keep this:

    auto lo
    iface lo inet loopback
    

It is very good idea to keep a backup copy of "interfaces" file just in case so please make sure to save a "interfaces.bak" file before you do anything

  1. Ctrl + O if you are using nano and Ctrl + S (File > Save) if you are using leafpad.

  2. Ctrl + X if you are using nano and Ctrl + Q (File > Quit) if you are using leafpad.

  3. Reboot.

  4. Done.

share|improve this answer
    
auto lo iface lo inet loopback doesn't work –  draw Mar 7 '13 at 17:11
    
@draw it has to be on two lines: 1st line is auto lo; 2nd line is iface lo inet loopback –  daniel kullmann May 27 '13 at 8:42
1  
@danielkullmann ; auto lo; (1st line) iface lo inet loopback; (2nd line) It doesn't work for me either. I need to manually configure the interface and give its address !! –  cognoz Jun 27 '13 at 6:48
1  
My interfaces file looks exactly like that but the problem persists /: –  Andy Nov 21 '14 at 17:05
2  
Note that this is only going to work if you have network-manager installed. It comes installed on the desktop version of Ubuntu, but not the server version. If you do not have network-manager installed, and you do this, then none of your interfaces will work –  jkurtisr32 Jan 2 at 15:54

This might help too: http://tech.pedersen-live.com/2012/05/disable-waiting-for-network-configuration-messages-on-ubuntu-boot/

Basically you edit this /etc/init/failsafe.conf file and disable (comment) the sleep commands which actually pause the system. Besides accomplishing the job, at least in my case there was no error at all in the network configuration, so everything went fine.

By the way, you solution only allows to configure the loopback interface, something I could not afford in my setup (I had to manually setup the interfaces and bridges).

share|improve this answer
    
This should be the correct answer. A lot of people feel that the functionality of failsafe.conf is overkill –  jkurtisr32 Jan 2 at 15:55

In every situation that I have run into this it is a problem in /etc/network/interfaces

You should not have to remove everything as suggested in an earlier post, but rather inspect for common problems.

In my case it was defining the gateway parameter for additional ethernet IPS. You only need to define the gateway for the primary interface for each card.

What I mean by this is if your file looks like this:

auto eth0
iface eth0 inet static
  address 10.0.0.5
  netmask 255.255.255.0
  network 10.0.0.0
  gateway 10.0.0.1

auto eth0:0
iface eth0:0 inet static
  address 10.0.0.6
  netmask 255.255.255.0
  network 10.0.0.0
  #gateway 10.0.0.1

The 2nd gateway param will cause ubuntu to hang for 60+ secs during boot, you only need to define the gateway for the first eth0 section, you DO need to define the gateway for any additional nic cards, IE eth1, wlan0 etc but NOT for additional IPS assigned to the same nic. Earlier version of Ubuntu did not have any issues with this, but Ubuntu 12.04 does not like it... Be nice if it could simply ignore it.

I'm sure there are other "problems" in this file that can cause this, so you should inspect the file and make sure there are no typos etc.

share|improve this answer
    
The "network" option is obsolete, no longer needed. –  jdthood Mar 25 '13 at 11:29
2  
this answer does not apply to me, I have no gateways in any active stanzas of this file –  memnoch_proxy Jul 23 '13 at 2:41
    
This was the answer that I needed –  Patrick Chu May 23 at 14:42
    
I had precisely the same problem and this solution worked perfectly! –  Samir Jul 6 at 10:35

Add a # in the /etc/init/failsafe.conf file in front of all lines containing sleep <n>. Doing so would help to boot fast.

This would lead to a faster boot, and it would not fix any issues with the /etc/network/interfaces file. Fixing issues with the /etc/network/interfaces file is not the purpose of /etc/init/failsafe.conf file.

There are situations where you want the network interface to not work (i.e. have a laptop that only has the eth0 interface (wired connection) plugged in some of the time). I don't want to have to wait 2 extra minutes for my laptop to boot because I don't have the wired connection plugged in.

share|improve this answer
3  
Could some of those lines (and the deliberate delays they produce) be important? If not, I recommend expanding this answer to explain why. –  Eliah Kagan Mar 25 '13 at 11:43

I had a similar problem. By running ifconfig -a, I determined that the only network devices on my computer were p4p1 and lo. There was no eth0.

So I edited /etc/network/interfaces, replacing all instances of eth0 with p4p1. The file's contents are now:

auto lo
iface lo inet loopback

auto p4p1
iface p4p1 inet dhcp

After rebooting, the networking was working fine.

If it matters, I was using Ubuntu 12.04.5 Server edition.

share|improve this answer

protected by Community Jan 13 '14 at 20:51

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.