Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Ubuntu 12.04 using Unity. To try it out, I installed the xubuntu-desktop package. Ever since I have a orange or red update notification (see attachment) in my Unity indicator panel, telling me about recommended and security updates, respectively.

Q: How can I disable the notifications?

What i expect to happen: There is an option to show these updates when you press the update notification. I disabled it and thought it wouldn't show again after a reboot. In addition, I ran dconf-editor and manually checked if the option to hide updates is enabled.

What happened instead: The update notifications are still there, the only way to get rid of them is to do the updates.

Update Notification

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I don't know if this is a solution or just a workaround to your problem , but you can disable the update-notifier from startup applications. I think you will not receive anymore update-notifications then.

Open a terminal and give this command

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' -i /etc/xdg/autostart/update-notifier.desktop

Then try to disable it from startup applications and see if your problem solved.

OR

take a look inside /etc/xdg/lxsession and see if is something there related to update-notifier

share|improve this answer
    
I tried both approaches, neither seems to work. unfortunately the first command, albeit successfully changing NoDisplay=true to NoDisplay=false, does not show any effect. In /etc/xdg/lxsession I have two folders (Lubuntu & Lubuntu-Netbook), I renamed both, although I couldn't find any relation to update-notifier. –  flomar Nov 6 '12 at 15:22
    
The effect of first command is to see the entry of update.notifier in startup applications , because is hidden by default. See now in startup applications and disable (un-mark) the entry. –  NikTh Nov 6 '12 at 15:27
    
I should have read your answer more closely, you are right, upon entering the above command a new entry "Update notifier" appears in "Startup applications". Once disabled, on the next reboot the notification is gone. Thanks! –  flomar Nov 7 '12 at 13:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.