Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like install liquid 2.2.2 for jekyll. However, the latest version of jekyll is 2.3.0. How to install a older version of package like liquid 2.2.2 in Ubuntu 12.10?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted
  1. you can downgrade your installed packages with this code :
    dpkg -i --force-downgrade /var/cache/apt/archives/APPLICATION-NAME-#
    # : means the version number currently installed.
  2. you can remove your package with :
    dpkg -r APPLICATION-NAME-#
    and then download desired version in .deb format, and install it.
  3. Your system generally has multiple versions of a package available in its repositories ,It means when Ubuntu updates a package, it places the new, updated package in a special updates repository. The old package is still located an Ubuntu’s main repository and can be installed with a few tricks. If you’ve installed a newer version of a package from a personal package archive (PPA), the older packages included with Ubuntu are still located in Ubuntu’s repositories.
    if you use Synaptic for managing your Packages, you can do this :

    • search for application you want and select it :

      you can use QuickFilter to find your application, and then select it from result

    • from menu select Package and select Force Version :

      you can use Ctrl+E to use Force Version

    • new window opened and you can select which version you want, and click on Force Version button :

      select version from drop-box

    • now this window closed and you return to Synaptic window, and you see the red icon inside the application checkbox, and Apply button now enabled, click on Apply to apply your changes :

      click Apply

NOTE : After downgrade this package, select it and go to Package menu and select Lock Version option. If you don’t do this, Ubuntu will try to upgrade the installed package the next time you update your installed packages.

share|improve this answer
add comment

I'm guessing this has to do with GitHub pages...

sudo gem uninstall jekyll
sudo gem install jekyll --version '= 0.11.0'

This will install liquid 2.4.1 (as of writing this), so you'll need to uninstall liquid (and confirm the alert about broken dependencies) before you install 2.2.2

sudo gem uninstall liquid
sudo gem install liquid --version '= 2.2.2'
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.