Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running ubuntu 12.10. I've set up raid5 using 3 HDDs: /dev/sda, /dev/sdb, and /dev/sdc. However on every boot I get this screen:

enter image description here

Which says

raid level 5 active with 2 out of 3 devices, algorithm 2, warning: there appears to be one or more degraded devices".

Output of /etc/mdadm/mdadm.conf:

CREATE owner=root group=disk mode=0660 auto=yes
HOMEHOST <system>
MAILADDR root
ARRAY /dev/md0 metadata=1.2 spares=1 name=bluelady:0 UUID=e0839614:9f79606f:75191039:19d511db

Output of /proc/mdstat:

Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10] 
md127 : active (auto-read-only) raid5 sda[0] sdc[3] sdb[1]
      7813774336 blocks super 1.2 level 5, 512k chunk, algorithm 2 [3/2] [UU_]
unused devices: <none>

Output of /etc/fstab:

/dev/md0                    /data       auto    defaults,user,owner 0   2

So far I've tried adding bootdegraded=true to kernel options which makes boot succeed but with some errors on boot but raid volume is mounted. I've also tried changing /etc/fstab to:

/dev/md127 /data auto defaults,user,owner 0 2

as /dev/md0 doesn't actually exist on my system. I've also tried changing the /etc/mdadm.conf last line to:

ARRAY /dev/md0 level=raid5 num-devices=3 metadata=1.2 name=bluelady:0 UUId=blahblahblah

Obviously the UUID is correct. I've just not typed it out here.

I've also noticed that there is an open bug on this subject: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/990913.

I can mount the raid array once booted in but on boot it has issues.

Is this a known issue? If not what can I try to fix this issue?

share|improve this question

closed as off topic by psusi, Mik, nitstorm, Takkat, belacqua Nov 6 '12 at 21:38

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You should follow the bug report. –  psusi Nov 6 '12 at 15:00
    
Welcome to Ask Ubuntu! This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  nitstorm Nov 6 '12 at 18:32

Browse other questions tagged or ask your own question.