Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using ethernet connection, I cannot establish a internet connection on my chromium browser, received a DNS error (or something related to that. I am very sure that I don't have any parental controls. Recently uninstalled apache2. Wireless internet works. Need more infos, please answer.

Notes :

  • When I tried to access internet through firefox, it does not work too.
  • The internet connection works perfectly on my mac.
  • Using the same PC, I tried to install windows and tried the network, it does not work too. Looks like it only works on separate computers (different computers).

Results from past tests :

$ ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:23:8b:c9:c3:0c  
          inet6 addr: fe80::223:8bff:fec9:c30c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:84 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1904 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:13190 (13.1 KB)  TX bytes:155642 (155.6 KB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:773 errors:0 dropped:0 overruns:0 frame:0
          TX packets:773 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:67773 (67.7 KB)  TX bytes:67773 (67.7 KB)

wlan0     Link encap:Ethernet  HWaddr 00:22:fa:dd:d5:8e  
          inet addr:192.168.1.106  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::222:faff:fedd:d58e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11885 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6671 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:17038008 (17.0 MB)  TX bytes:592304 (592.3 KB)

Command : sudo lshw -C network

$ sudo lshw -C network

 *-network               
   description: Ethernet interface
   product: 88E8072 PCI-E Gigabit Ethernet Controller
   vendor: Marvell Technology Group Ltd.
   physical id: 0
   bus info: pci@0000:07:00.0
   logical name: eth0
   version: 16
   serial: 00:23:8b:c9:c3:0c
   size: 100Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 duplex=full latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
   resources: irq:44 memory:c0400000-c0403fff ioport:3000(size=256) memory:c0700000-c071ffff


  *-network
   description: Wireless interface
   product: WiFi Link 5100
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:08:00.0
   logical name: wlan0
   version: 00
   serial: 00:22:fa:dd:d5:8e
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.5.0-17-generic 

More information :

I have checked, trying to boot into windows, neither the network using ethernet worked there. I tried to diagnose it, here is the result: Your computer appears to be correctly configured, but the device or resource (DNS server) is not responding. I believe I tried both wall power and battery power. 2. I use Ubuntu Desktop, so "NetworkManager".

share|improve this question
    
Please open a terminal and run ping www.google.com then host www.google.com then cat /etc/resolv.conf. Post these commands and their output after your question. –  jdthood Nov 6 '12 at 13:07
1  
result :jianyue@jianyue:~$ ping www.google.com ping: unknown host www.google.com jianyue@jianyue:~$ host www.google.com ;; connection timed out; no servers could be reached jianyue@jianyue:~$ cat /etc/resolv.conf # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN nameserver 127.0.1.1 jianyue@jianyue:~$ –  owl Nov 6 '12 at 13:30
add comment

1 Answer

The output from ifconfig indicates that eth0, your Ethernet interface, does not have an IPv4 address. It has not been configured properly.

share|improve this answer
    
How can I configure it properly? –  owl Nov 6 '12 at 13:47
    
Hmm... Are you running a laptop on battery? Put it on wall power, then use the network indicator to disable and enable networking. Ref: bug #1053945. –  jdthood Nov 6 '12 at 14:01
    
Are you using NetworkManager or ifup to configure your interfaces? –  jdthood Nov 6 '12 at 14:13
    
I have tried running my laptop on battery, disable and enable networking and it does not work. I don't use NetworkManager or ifup to configure my interfaces. –  owl Nov 6 '12 at 14:37
    
1. When you run a laptop on battery power the kernel sometimes shuts off peripheral devices and this can cause nonfunctioning such as you are experiencing. So it's better to run on wall power. 2. What program do you use to configure your interfaces? If you installed Ubuntu Desktop then by default you are using NetworkManager. If you installed Ubuntu Server then by default you are using ifup. –  jdthood Nov 6 '12 at 14:54
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.