Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Laptop is Acer 5742G with "Npilfy 802.11 wireless".

I have both windows 7 and Ubuntu 12.10

Earlier when I had Ubuntu 12.04, the wireless was working fine, but after installing 12.10 wireless is not working at all, although it is still working in windows.

I am not able to see "Wireless Networks" in the Network Manager nor in the Network Settings.

This was the output I got for rfkill

0: acer-wireless: Wireless LAN
    Soft blocked: no  
    Hard blocked: no  
1: acer-bluetooth: Bluetooth  
    Soft blocked: no  
    Hard blocked: no  
2: hci0: Bluetooth  
    Soft blocked: no  
    Hard blocked: no

This is a snapshot of my Additional Drivers settings. Drivers

As you can see, the required driver for wireless is installed.

share|improve this question
up vote 19 down vote accepted

Your problem looks similar to mine, and I think the new kernel and broadcom drivers are the connection. I ran

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

and it worked for me on a Samsung netbook.

share|improve this answer
1  
Why are you posting the same answer as that already existed? – gertvdijk Oct 17 '13 at 21:46

Please check:

lspci -nn

Is it's pci.id 14e4:4727? If so, this may be helpful:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl
share|improve this answer

Similar thing happened to me, and I believe my answer is more shifted towards the UI but I think it is basically the same thing as DrA proposed:

  1. Install linux-headers-generic (via software center or terminal).
  2. In sofware origins > Additional drivers tab, check "Do not use this driver" & apply.
  3. Then check again to use Broadcomm propietary driver and apply.

In fact this also worked for me in another laptop that had issues with nvidia drivers.

share|improve this answer

protected by Community Jan 12 '13 at 8:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.