Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The default behavior in the Nexus 7 Image is to log straight in to the default user's desktop, bypassing the lightdm greeter. This seems like an acceptable behavior for testing the core but it's clearly insecure.

I've changed the default password and would like lightdm to actually require the password to be entered, rather than just having a button that says "login". I've turned automatic login on and off in System Settings → User Accounts but this doesn't help.

Any suggestions?

share|improve this question

About the Passwords...

Eventually the image will be just like any other desktop where you are prompted for a user/password, timezone, etc. It's being worked on.

Disabling Autologin

Edit (with sudo) /etc/lightdm/lightdm.conf and comment out (with a #) the line that says

autologin-user=ubuntu

Like this:

#autologin-user=ubuntu

Then reboot or restart lightdm.

Also please file a bug on this, I think the behavior should be consistent when you change those system settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.