Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.10, today update notification popped up and I updated the system, then it asked for restart, I was doing some stuff so I restarted after ~30 minutes, after restart, Ubuntu GUI was gone, there was no taskbar or unity, I fixed by entering this commands:

sudo apt-get install linux-source 
sudo apt-get install linux-headers-generic
sudo apt-get remove nvidia-current-updates
sudo apt-get install nvidia-current-updates

... these commands fixed almost everything, unity is running, but there's problem when I go in terminal ctrl+alt+F1, before I write anything, many many messages appear, it says "Buffer I/O error on device fd0, logical block 0", what should I do?

Here's image: http://i.imgur.com/JBD5x.jpg

Another thing I noticed is that after few about an hour, messages disappear, this error keeps showing up for first hour roughly.

share|improve this question
add comment

3 Answers

up vote 7 down vote accepted

This is indeed most likely an issue with Ubuntu thinking you have a floppy drive when you do not, and it thinks that because your BIOS is telling it to think that.

My BIOS is an Award Software BIOS; I believe Phoenix is the same company.

  1. At boot of computer, press DEL to enter BIOS setup (this might be a different key, but your post screen probably will tell you what to hit if it's not DEL.)

  2. In the BIOS, find the section that lists different drives (hard drives, floppies, etc). Mine was in Standard CMOS Features.

  3. Select Drive A, and change to None.

  4. Reboot, and your imaginary floppy won't be reported by the BIOS to Ubuntu!

Thank to Rrinzwind, who set me on finding out about disabling the floppy drive, and this forum thread which explained what was happening.

share|improve this answer
    
Thank you for the answer, I am having problems with my BIOS lately and that's probably the issue. Thanks for the help. –  Paul Dirac Dec 29 '12 at 9:03
add comment

This message appears when you don’t have a floppy drive attached. Solution is quite simple just disable driver for floppy and reboot the system.

Disable it with the following edit:

vi /etc/modprobe.d/blacklist

Add to this file

blacklist floppy

and reboot. Messages should be gone.


Even easier (this does both in 1 line):

sudo tee -a /etc/modprobe.d/blacklist.conf <<<"blacklist floppy"
share|improve this answer
    
Thanks for the help, but messages still show up, even after I edit config file. –  Paul Dirac Nov 6 '12 at 8:10
add comment

Try booting the live cd and when you are at the main menu of the live cd press F6 and add

all_generic_ide

to the end of the line as a boot option.

share|improve this answer
    
You mean ubuntu live cd right? when I boot live cd, it doesn't show me any menus, after some waiting, it just gives me two options, "Try ubuntu" or "Install", may I add that line in grub menu? theres boot commands in grub menu if I press "e", should I add all_generic_ide there? –  Paul Dirac Nov 6 '12 at 11:57
    
I added it to the boot commands in grub menu but still nothing, and I can't make live cd to show it's menu for some reason, it just starts at the desktop. –  Paul Dirac Nov 6 '12 at 12:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.