Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently did the update from 12.04 to 12.10 on my old Dell Latitude CPx laptop (Pentium III). When I rebooted I got this error message with no response from keyboard input. Below it is says

Wait to continue, press S to skip mounting, or M for manual recovery.

I also see occasional errors pop up on the screen from mountall and Plymouth. I can still get into Recovery Mode. Can anyone shed some light on the matter?

Update: I redid my fstab, to no avail. Now my screen is flashing on and off from the Ubuntu 12.10 splash screen to a black screen. I would really love to avoid a reinstall...

share|improve this question
up vote 0 down vote accepted

Looks like the UUIDs of some of your partitions have changed. And your /etc/fstab specifies the old UUID so it is not able to mount / and some other partitions during boot process.

If you have a Ubuntu 12.10 desktop CD (Live), boot from it, open a Terminal

Run blkid to get the list of UUIDs for all your block devices/logical volumes.

Then mount your /, for example if your root partition is on /dev/sda2 and type is ext4

cd /mnt
mkdir root
mount -t ext4 /dev/sda2 /mnt/root
nano /mnt/root/etc/fstab

Make sure the UUIDs of partitions/block devices are correct, if not, update and save.

NOTE: if you don't like UUID, just use traditional block device, e.g. /dev/sda2 instead of UUID=x

Then run

sync; sync; cd /mnt; umount /dev/sda2; reboot

You should be back on track.

share|improve this answer
Thanks for the reply. The error message is gone but now my screen is flashing on and off from the Ubuntu 12.10 boot splash screen and a black screen. – Richard Nov 8 '12 at 21:08
This could be video driver issue. Anyway, you can disable the boot splash and see the output by commenting out the following line in /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="splash quiet", don't forget to run update-grub to reflect the change. The output during boot should be of some help. – Terry Wang Nov 8 '12 at 23:39
This happens from time to time with me. It has nothing to do with partitions being changed. – JohnMerlino Apr 12 '14 at 17:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.