Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There are some Internet hits for this query, but none has a satisfying answer.

How can I make VLC and xscreensaver play nice together on Ubuntu 12.10 (using xmonad, not Unity or GNOME or anything)?

I want any fullscreen application (in xmonad) and VLC to completely disable xscreensaver from taking any automatic actions. Essentially if VLC changed xscreensaver.timeout to infinity while playing, that would be perfect.

I do not want to have to run a shell script to disable the screensaver.

share|improve this question

1 Answer 1

You should be able to disable the screensaver in fullscreen VLC from the Preferences > Video > Show all settings > Disable Screensaver.

To disable it for other fullscreen video applications you can try the lightsOn.sh script from here.

I'm wasn't sure what you mean by

I do not want to have to run a shell script to disable the screensaver.

I take it that it means that you don't want to manually run a shell script.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.