Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

We have an Ubuntu 12.04 box that has high latency, 50ms to 90ms. Pinging it from a box right next to it gives me this output:

Reply from 10.10.1.14: bytes=32 time=91ms TTL=64
Reply from 10.10.1.14: bytes=32 time=58ms TTL=64
Reply from 10.10.1.14: bytes=32 time=85ms TTL=64
Reply from 10.10.1.14: bytes=32 time=82ms TTL=64

This seems high for a box that does not do much if anything at all. It hosts a internal wordpress site that rarely get's used. The latency is just enough to make the box annoying to use (through vnc).

PC's connected to the same switch get 1ms and less from my workstation:

Reply from 10.10.1.210: bytes=32 time<1ms TTL=128
Reply from 10.10.1.210: bytes=32 time<1ms TTL=128
Reply from 10.10.1.210: bytes=32 time<1ms TTL=128
Reply from 10.10.1.210: bytes=32 time<1ms TTL=128

I've no clue where to start troubleshooting this. Here are some system specs if that helps:

Intel Core i5-2400 3.1GHz, 4GB DDR3, Intel Gigabit Ethernet

Here is the ifconfig output:

Link encap:Ethernet  HWaddr 00:07:e9:0c:fc:89  
          inet addr:10.10.1.14  Bcast:10.10.1.255  Mask:255.255.255.0
          inet6 addr: fe80::207:e9ff:fe0c:fc89/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:64080 errors:0 dropped:551 overruns:0 frame:0
          TX packets:18377 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8471337 (8.4 MB)  TX bytes:19614700 (19.6 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:678 errors:0 dropped:0 overruns:0 frame:0
          TX packets:678 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:60515 (60.5 KB)  TX bytes:60515 (60.5 KB)

top shows average load of 0.07 with Xorg being the highest cpu usage at 2%.

There is nothing between this box and my workstation, no firewall, no routers, just a gigabit switch. All on the same subnet.

The Active Network Connections window says Driver: e1000 Speed: 1000 Mb/s Security: None.

share|improve this question
    
Have you ensured that speed/duplex of the ports both switch and machine side are matching? –  RWC Nov 5 '12 at 22:41
    
Yes, just for kicks, I just played around with setting the speed to 100, then duplex to half, neither (and both) did not make a change to the latency. –  mxmissile Nov 5 '12 at 23:03
    
Change the port on the switch to one with no known issues, as a test. Change the cable with a known good cable. –  belacqua Nov 8 '12 at 20:19
    
Have replaced the cable, and tried a completely different switch. –  mxmissile Jan 8 '13 at 17:23
    
I have a similar problem, but latency to LAN is 300ms-3s. Tried replacing switch, nic and cable. Is there a possible OS cause? The traffic on this interface is only a a few MB per min. –  chrisdew Apr 10 '13 at 7:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.