Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.


i have last ubuntu installed (10.10), but from an year and thousand updates, video drivers updates, an hundreds of tricks, the mouse pointer is showed like an UGLY square...

These are the screenshots:

alt text
alt text

I have no idea what to do to solve this problem. Anyone of you have an idea to solve it?

Edit: this problem was encountered from 8.10+!

Edit 2, Video card specifications:

paska@ubuntu:~$ hwinfo --gfxcard
35: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1106_3230
  Unique ID: VCu0.QX54AGQKWeE
  Parent ID: vSkL.CP+qXDDqow8
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "VIA K8M890CE/K8N890CE [Chrome 9]"
  Vendor: pci 0x1106 "VIA Technologies, Inc."
  Device: pci 0x3230 "K8M890CE/K8N890CE [Chrome 9]"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x81b5 
  Revision: 0x11
  Memory Range: 0xd0000000-0xdfffffff (rw,prefetchable)
  Memory Range: 0xfa000000-0xfaffffff (rw,non-prefetchable)
  Memory Range: 0xfbcf0000-0xfbcfffff (ro,prefetchable,disabled)
  IRQ: 16 (10026 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001106d00003230sv00001043sd000081B5bc03sc00i00"
  Driver Info #0:
    Driver Status: viafb is not active
    Driver Activation Cmd: "modprobe viafb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)

Primary display adapter: #35
paska@ubuntu:~$ 

thanks,
A

share|improve this question
    
Do you have ATI graphics? This is a problem with ATI graphics drivers that is known, and if I remember correctly there is a fix for it. –  RolandiXor Jan 13 '11 at 0:55
    
another thing, to save a screenshot all you have to do is press print scrn on your keyboard. –  RolandiXor Jan 13 '11 at 0:59
    
@Roland, print screen don't save mouse pointer... –  elpsk Jan 13 '11 at 9:29
    
@Paska Ya it does. Look at i.imgur.com/PfVQd.png –  binW Jan 13 '11 at 10:37
    
@binW haha windows doesn't! right! :) –  elpsk Jan 13 '11 at 10:39

2 Answers 2

up vote 2 down vote accepted

You have a VIA graphics card, it's one of the worst supported graphics chipsets.

What is happening is that the hardware cursor (that's a special part of the graphic card capability that produces a nice smooth cursor) has been corrupted. Normally this is because all of your video memory has been used.

If you can go into the bios and increase the amount of RAM given to the onboard video device. This may solve the issue for you.

It may still be a driver issue, as I said at the start, VIA isn't well supported so you may want to upgrade to an nvidia, intel or ati graphics card.

share|improve this answer
    
nothing... it's the same, thanks –  elpsk Mar 18 '11 at 12:50

If your /etc/X11/xorg.conf file exists and has a Device section, you can set it to use a software cursor. Just add the line

Option        "SWCursor" "true"

in that section. This should make the cursor be rendered in software, not by the graphics card.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.