Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can use suspend without any problem if I do it manually. It resumes OK as well.

However, for some reason it has stopped doing this automatically. Right now it is set to suspend after 30 minutes but it can be idle for hours without suspending.

share|improve this question

closed as too localized by Jorge Castro, Mitch, Eliah Kagan, hbdgaf, Jacob Johan Edwards Aug 31 '12 at 21:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

I would check for any USB devices such as mouses, keyboards, or WLAN adapters... or even a NIC card might be causing it not to sleep... what you could do is set your suspend to 5 mins or something, and eliminate each one, till it works... if it works then you know that device is the cause... if it doesn't work then maybe someone else might have an idea... I have never had this issue on Ubuntu, but I have had it on Windows.... and this is the method I use to troubleshoot it.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.