Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two monitors, which I have set up with nvidia-settings in Twinview. The result: When I want to do something in xRandR, it does not function. It doesn't report one output per video card head, but a single output mapped to the combined area of both monitors:

rumtscho@bradbury:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 3840 x 1440, current 3840 x 1440, maximum 3840 x 1440
default connected 3840x1440+0+0 0mm x 0mm
   3840x1440      50.0*

Now I promised somebody to help test a driver. The developer is using an open source driver for Intel video cards, and his driver assumes that there is more than one xRandR output, each mapped to a monitor. So I tried rewriting my xorg.conf to somehow get two outputs to show up, but failed. Googling showed that people faced with the xRandR-nvidia problem either stopped using xRandR and achieved what they needed with nvidia-settings, or changed their driver to nouveau.

The first is not going to help in my situation, and I am not willing to give up the proprietary driver, because Compiz won't work without it. So does anybody know a way to get nvidia to actually pass on information on outputs to xRandR?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The proprietary driver isn't compatible with xrandr and it likely never will be. Nvidia have refused to create a compatible driver and instead have decided to copy their windows based settings and controls.

Over time, the nvidia driver is likely to fall further and further behind, making it harder and harder to use in a modern FreeDesktop like Ubuntu. You must instead use the nvidia-settings and the twinview, which distorts the desktop across two screens.

share|improve this answer
    
Yes, I searched more about it and my impression was the same. I wouldn't mind using an open source driver, but for now it cannot do everything I need. –  rumtscho Jan 27 '11 at 21:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.