Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i have an executable script and i runs it by double-clicking it in Gnome.

It opens a dialoguebox that asks, what is intended to do:

  • execute in terminal
  • view
  • cancel
  • execute

Is there a way to avoid this question in for certain selected scripts?

alt text

share|improve this question

2 Answers 2

up vote 6 down vote accepted
  • In nautilus goto Edit Preferences and then select Behavior tab.
  • Under Executable Text files select "View executable text files when they are opened" or select "Run executable text files when they are opened".

    alt text

  • Now that dialog will get disappeared.
share|improve this answer

In Nautilus... Edit->Preferences->Behavior and look under Executable Text Files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.