Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The anti-aliasing of my system (of GTK?) has gone weird after I did one of two things - do a system update, and install gimp 2.7 beta. See images:

Before:        After:

alt text alt text

Before: After:

alt text alt text

Here's the current rendering comparison between Chromium, Firefox and Opera (in that order):

alt text

alt text

alt text

Does anyone know how I can get the old anti-aliasing back? As far as I can tell, I never did anything special to achieve that before. It has always been on the default settings since I installed Lucid few months ago.

Update: I have tried different settings (even though I knew they were already at the "best" settings) in appearance > fonts ( > details) but, as expected, any change there only makes things worse.

Update 2: One/some of these packages are to blame I'm sure:

libc-bin (2.11.1-0ubuntu7.6) to 2.11.1-0ubuntu7.7
libc-dev-bin (2.11.1-0ubuntu7.6) to 2.11.1-0ubuntu7.7
libc6 (2.11.1-0ubuntu7.6) to 2.11.1-0ubuntu7.7
libc6-dev (2.11.1-0ubuntu7.6) to 2.11.1-0ubuntu7.7
libc6-i686 (2.11.1-0ubuntu7.6) to 2.11.1-0ubuntu7.7
libcairo2 (1.8.10-2ubuntu1) to 1.9.6-6~mrw4
libcairo2-dev (1.8.10-2ubuntu1) to 1.9.6-6~mrw4
libgegl-0.0-0 (0.0.22-0ubuntu4) to 0.1.3-2010091001~ll
liblcms1 (1.18.dfsg-1ubuntu2) to 1.18.dfsg-1ubuntu2.10.04.1
share|improve this question
    
Have you tried the different options in System->Preferences->Appearance->Fonts? –  8128 Jan 12 '11 at 18:44
    
Thanks for the prompt response. Should've known it would be a common query. Have updated question. –  Mussnoon Jan 12 '11 at 18:54
1  
Try checking Synaptic's "history" (File/History) to see if you've installed any software that might affect this (QT perhaps, or fonts). Are you still using the same fonts in Appearance (you've checked the subpixel rendering, but is the actual font the same)? –  Scaine Jan 12 '11 at 19:11
    
Yes..I certainly installed something that is affecting this. Checking history now. Also, the font is the same - Ubuntu. I've even changed the font to a different one and setting it back to Ubuntu - didn't work. –  Mussnoon Jan 12 '11 at 19:16
    
@Scaine Thanks a lot. I had thought there was no history for Synaptic, but going through it indeed helped me fix the problem. –  Mussnoon Jan 13 '11 at 0:22

1 Answer 1

up vote 0 down vote accepted

I went through the descriptions of the listed packages in Synaptic, and figured what was causing it. It was libcairo2. And this (and -dev) was the only package from an unofficial ppa. So I downgraded the two packages like so:

sudo apt-get install libcairo2=1.8.10-2ubuntu1 libcairo2-dev=1.8.10-2ubuntu1

then restarted X-server and now it's back to the rendering style.

alt text

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.