Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a problem with my subversion in Ubuntu, and it's happening only on my computer, my colleagues are working fine. It asks for password for user "(null)":

Password for '(null)' GNOME keyring:

entering the password it shows:

svn: OPTIONS of 'http://10.0.203.3/greenfox': authorization failed: Could not authenticate to server: rejected Basic challenge (http://10.0.203.3)

What can be causing that (again: it's just on my computer, the svn server is ok).

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted
+50

I found the bug here.

The following should solve the issue:

rm ~/.gnome2/keyrings/login.keyring
share|improve this answer
2  
Could you add more information like: Any work arounds, why this bug exists, etc? Just pointing out that it's a "bug" doesn't constitute much of an answer. –  Marco Ceppi Jan 15 '11 at 17:39
1  
solved with this comment: bugs.launchpad.net/ubuntu/+source/subversion/+bug/473139/… –  Tom Brito Jan 17 '11 at 12:37
add comment

I run into this issue in my

  • Xubuntu 11.10 and SVN 1.6.12
  • Xubuntu 12.04 and SVN 1.6.17

every now and then (no idea what triggers the issue).

The magic that I found from the comments to the Javier González' answer is:

$ rm ~/.gnome2/keyrings/login.keyring

Posted as an answer so that I'll find this faster next time ...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.