Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was thinking about buying a Raspberry Pi, and running Ubuntu on it. I have looked around the web, and a lot of stuff says that it's difficult for it to work on ARM processors. Has anyone figured out how to get a Raspberry pi to run Ubuntu?

share|improve this question
add comment

3 Answers

up vote 28 down vote accepted

From the Official FAQ Page at Raspberry Pi:

What Linux distros will be supported at launch?

Fedora, Debian and ArchLinux will be supported from the start. We hope to see support from other distros later. (Because of issues with newer releases of Ubuntu and the ARM processor we are using, Ubuntu can’t commit to support Raspberry Pi at the moment.) You will be able to download distro images from us as soon as the Raspberry Pi is released, and we will also be selling pre-loaded SD cards shortly after release.


Source: My answer on Raspberry Pi SE

share|improve this answer
2  
Thanks. I hope they make it work for the Raspberry pi soon. I know a lot of people would be in favor of that. –  Jordan Nov 6 '12 at 16:26
2  
Or they will move on to a board that supports it. cubieboard.org –  Mateo Feb 1 '13 at 0:54
add comment

Currently not - Canonical only support ARM's ARMv7 processor architecture and the Pi has an ARMv6 chip.

share|improve this answer
add comment

The complications you refer to regarding ARM are a common issue for all distributions, they are not Ubuntu-specific. They stem from the fact that ARM has a number of different architectures, offering limited to no compatibility between each other.

The leading Linux ARM distributions are the following (excluding Gentoo which by definition is compiled to the exact target), and I am listing the corresponding target architecture:

Ubuntu: ARMv7 and up, thumb 2 (32 bit)
Debian: ARMv4t and up (armel) ARMv7 and up (armhf)
Fedora: ARMv5tel (arm) ARMv7hl (armhf)
Arch Linux: ARMv5te or higher

To your specific question, the Raspberry PI runs a BCM2835 (ARM1176JZF-S) Broadcom CPU. This is armv6k architecture, which is not compatible with recent builds of Ubuntu, which are optimized for performance at the expense of compatibility with older chip designs like this Broadcom's.

The obvious choice is to run the armel architecture of Debian -- you will feel almost at home as if you were on Ubuntu.

share|improve this answer
    
Then what older builds of Ubuntu do run on the Pi? –  Mathias Lykkegaard Lorenzen Jul 31 '13 at 22:16
    
I expect 9.04 would work fine, but I am not sure why you wouldn't just use a current Debian instead. –  0xF2 Jul 31 '13 at 23:44
    
I need compatibility with a specific WiFi dongle that I know works with Ubuntu. I haven't bought the dongle nor the Pi itself yet, but I just want a Whole setup that's guaranteed to work. –  Mathias Lykkegaard Lorenzen Aug 1 '13 at 9:10
add comment

protected by Community Apr 24 '13 at 3:53

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.