Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently posted a question but couldn't get any help from it so here goes again: I am new to Linux. I downloaded Ubuntu 12.10 onto a USB drive to put on an old laptop just for fun. I realized that Ubuntu is awesome and wanted to install it. The install worked fine but here is the problem:

when I boot it from the hard drive I can't get wireless. There are no wireless routers listed, nor is "enable wireless".

When I boot it from the USB drive (i.e. "Try Ubuntu" at the first pop-up) it automatically connects to wireless. A dozen nearby routers show up and "enable wireless" is visible. I cannot just boot from USB every time because it is only 4GB compared to a 500GB hard drive.

I really want to use Ubuntu; it seems great, but I also need wireless service. Am I using a wrong form of Ubuntu? What is the problem here, and how do I fix it?

Thank you so much for helping me.

share|improve this question
add comment

1 Answer 1

Seems like you've driver problem, but to be sure try the following:
1. Is you wireless card detected?

Run the following command in terminal(CTRL-ALT-T)

sudo lshw -C network

2. In case your card is disabled, enable it by:

sudo rfkill unblock wifi

3. If it still doesn't works, update your system(Dash > Update Manager).

This will update your driver.

4. Still doesn't works, search for additional driver(Dash > Additional Drivers)
If a wifi driver is listed (Broadcom or anything else) install it.

More resources:
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.