Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is when I set XWinWrap to play a video for my desktop in the startup applications, when I first log in it covers the taskbar as well, the launcher is inaccessible as well. I can use super key to start a program and all is well after that, but I am wondering if there is a way to set XWinWrap to where it does not do this at all.

This page that contains information about how to use XWinWrap.

Command line that I use in startup applications:

xwinwrap -ni -o 0.6 -fs -s -st -sp -b -nf -- mplayer -wid WID -nosound /path/to/video/file.mp4

or even if you just have another method to play videos as your desktop background that works more efficiently than this one, I am not stuck on absolutely having to use this particular method, so long as the end result is the same.

share|improve this question
add comment

1 Answer

Also using Ubuntu 12.04 I use XWinWrap with the geometry (-g) option to maximize the screen other wise I've found I lose my taskbar icons as well. These are the options I use for the Electric sheep screensaver.

xwinwrap -ni -o 0.4 -s -st -sp -b -nf -g 1440x900 -- /usr/bin/electricsheep -window-id WID

You can try removing the -fs option and adding in -g for your display resolution.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.