Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded and installed Ubuntu using the Windows installer. Everything is running smoothly. When I plug in my ethernet cable is recognizes that it is plugged in and says that I am connected. Whenever I try to access Firefox it says Firefox cannot locate the server. Any suggestions? I am very new to Linux as well as using cmd prompts for the terminal.

share|improve this question
1  
Are you connected to the internet via a proxy? –  nitstorm Nov 5 '12 at 16:50
    
please open terminal and type: ping google.com after 5 retry press ctrl+c to stop it the see you have access to internet or not. if you are connected to internet, you will see this report at the end of ping log: 3 packets transmitted, 3 received, 0% packet loss, time 1999ms –  Ubuntu Helper Nov 5 '12 at 16:53
    
If you hit <kbd>ctrl</kbd><kbd>alt</kbd><kbd>t</kbd> from your desktop, it should open up a terminal window. From the terminal, what do you see if you type ifconfig and hit enter? It might be a lot of information, so you can also add a |less making the command ifconfig | less or > filename.txt making the command ifconfig > filename.txtand read the results in a text file by typing nano filename.txt or gedit filename.txt. Do you see a line that says inet addr: and your IP address? –  Slarty Nov 5 '12 at 16:54
    
No I am not connected via proxy –  Trisha Nov 5 '12 at 16:59
    
I retried 5 times and still could not connect –  Trisha Nov 5 '12 at 17:07
show 1 more comment

2 Answers

Lets see if its a DNS issue.

Type Network in your search and then open Network Connections. Under Wired you should see a connection named Auto eth0 as seen below.

Network Connections

Click Edit from the right and enter your password and you should see a window similar to the one below.

Connection Info

Now change the method to Automatic (DHCP) addresses only and down the bottom next to DNS servers enter 8.8.8.8,8.8.4.4 as seen below. These are DNS servers provided by Google and are very reliable.

DNS Settings

Now click Save down the bottom and lastly lets restart your network connections to make sure we are using the new settings. The easiest way is to turn your network off and on again as seen in the image below. But if you are comfortable with the terminal type Terminal in your search and open it up then type the following to restart your network connections.

$sudo service networking restart

Network Reset

Now lets check before trying the internet again so type Network in your search again and this time choose Network and you should see something similar to the image below.

Check Settings

Now try your browser again and let me know how you go.

share|improve this answer
add comment
  • Check what's in /etc/resolv.conf ( if you can paste the output that will help).
  • Also do 'route -n' and paste the output.

The reason why its not working could be the following. - Gateway is not reachable ( or there is a alternate gateway configured which is also not reachable )
- DNS server is not reachable

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.