Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot delete files, when I tried to delete the file, this message appeard:

"Error while deleting. There was an error deleting file2.rar."

This is what I get from clicking on SHOW MORE DETAILS:

"Error removing file: Read-only file system"

This is what I've tried so far:

  • deleting from the downloads directory from my user.
  • deleting permanently, but it does not work.

EDIT

When trying to remount it as read/write I get this error:

 ~$ sudo mount -o remount,rw /media/A88F-8788  
 [sudo] password for name:  
 sudo: unable to open /var/lib/sudo/jianyue/1: Read-only file system  
 mount: can't find /media/A88F-8788 in /etc/fstab or /etc/mtab

EDIT AGAIN

I heard it is one of the bugs, waiting to be fixed.

Just another edit on 2014

No information about the resolution of the bug. I've not tried it again since then, because I have re-installed the system and misplaced files.

share|improve this question
    
Please see possible duplicate question: How to delete/edit files from read-only filesystem? –  Peachy Nov 5 '12 at 10:52
    
You just copied the remount command from the other question. The path at the end has to point to the folder where that filesystem is mounted. –  André Stannek Nov 5 '12 at 11:21
    
I tried the command from another question, it does not work. So, I am asking the public, how to fix it. –  owl Nov 5 '12 at 12:39
3  
@tech What @stonedsquirrel is saying is that you need to change the /media/A88F-8788 part of the command to the partition that you want to change the permissions for. The OP of the linked question's partition was named A88F-8788 but yours will be different. Use mount -l to find out what the partition name is and replace the /media/A88F-8788 part of the command. For example, I have /dev/sda4 on /media/123 type ext4 (rw), I'd use sudo mount -o remount,rw /media/123 . That should work –  nitstorm Nov 5 '12 at 16:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.