Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Samsung 300v5a-s19ru laptop, and its WebCam is not recognized. I tried to follow this manual, but it doesn't work for me.

  1. When I'm trying to start Cheese, it doesn't see any WebCam at all. Its Output:

    ** (cheese:8161): WARNING **: cheese-main.vala:251: Error: No device found
    
       (cheese:8161): cheese-CRITICAL **: cheese_camera_device_get_device_node: assertion CHEESE_IS_CAMERA_DEVICE (device)' failed
    
       (cheese:8161): GLib-CRITICAL **: g_variant_new_string: assertion string != NULL' failed
    
       (cheese:8161): GLib-GIO-CRITICAL **: g_settings_schema_key_type_check: assertion value != NULL' failed
    
       (cheese:8161): GLib-CRITICAL **: g_variant_get_type_string: assertion value != NULL' failed
    
       (cheese:8161): GLib-GIO-CRITICAL **: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given
    
    ** (cheese:8161): CRITICAL **: cheese_preferences_dialog_setup_resolutions_for_device: assertion device != NULL' failed
    
  2. I tried install Ov51x, but as I can understand it doesn't work on linux kernel > 3.0. Trying to follow this, item 2.4 fails:

    % make

    make: *** No targets. Stop.

    In this answer on askubuntu it's written, that Ov51x works on < 2.6 kernels only

  3. In Samsung Tech Support they said that drivers for Linux does not exist, but they said also, that in my laptop WebCam Sunplus Tech SCB-1100N is used.

What do I do to make it work? What driver or module should I use?

Thanks in advance!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The solution was so simple and close

The issue was that the webcam is switched off at boot time with the Samsung Tools.

I accidentally discovered that in the settings of the Samsung Tools webcam toggle is set to "Last Status", which essentially means "Disabled", as the camera was never turned on before. I assign a shortcut key [Fn] + [F4] to turn on/off the camera. And now the camera switches on and off, and even works.

I apologize for making this stupid question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.