Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new Lenovo Ideapad Yoga 13. The onboard LAN/Bluetooth device is identified in Linux as 0bda:1724 (via lsusb). No network peripherals are reported from lspci.

Online, the vendor:product above looks to be RT2573, however, in Windows, the device is identified as RTL8723A.

I am trying to find a Linux kernel module (driver) for this WLAN card. I have tried rt2500usb, rt2x00usb, and rtl8723e, on 2.6.x and 3.x.x kernels, to no avail.

I've posted the output of lspci -nn -v and lsusb -v to:

share|improve this question
I'm successfully using Larry Finger's prototype driver, as mentioned on the Linux Kernel mailing list: – Stefan van der Walt Apr 28 '13 at 18:44
the driver is available on github: -- seemed to work well for my Yoga i7 on 13.04 – choover Jun 9 '13 at 17:53

I've emailed Realtek techsupport, and they've sent me some new driver (zip), that should suit this card. Download - I'm actually trying to get my Yoga's onboard Wi-Fi with this. Hope that helps someone.

share|improve this answer
Well, Greetings!, Wi-Fi is CONFIRMED WORKING on yoga 13 with this drive – x0wl Jan 31 '13 at 9:43
Good. Then get this with all its details in a bug report. This vendor/product ID seems not included in the mainline Linux kernel, so this needs patching. How do I report a bug? – gertvdijk Jan 31 '13 at 10:01
Has anybody managed to compile this with kernel 3.8? Or is there an updated driver? – aditsu Mar 7 '13 at 9:09
I have it working with the 3.8 kernel. This is the sketchiest thing ever. from:… If you are running Linux 3.8, as suggested for the touch screen, you may get an error when running "make" mentioning the "daemonize" function. This function has been removed from the kernel, for reasons the author is not familiar with so the following may create security problems. Open include/osdep_service.h and remove the line calling the daemonize function. (You do this at your own risk. You probably shouldn't do this...). – zgchurch Apr 18 '13 at 19:39

Have you tried the driver suggested in this post about the Realtek RTL8723AE-BT? If Windows is correct about the card, this model is very similar. I believe this is the link to the direct link to the wireless (non-BT) version of this driver.

I'd be curious to know if that works out for you, as I'm considering picking up a Yoga. Good luck to you.

share|improve this answer
Thanks Tohuw. I did try this driver prior to my posting. The source, as released by Realtek, only supported kernels up to 3.0, as far as I recall. Community patches provided support up to 3.4. Using either an earlier 3.x or 2.6 kernel, the kernel module loads, but no interface is created. – ryanjn Nov 16 '12 at 4:04

Some of the puzzle ..

vendor: 0b05 is "ASUSTek Computer, Inc."

vendor: 0bda is "Realtek Semiconductor Corp."

vendor: 0b05, product: 1724 is an OEM Realtek 'RT2573'

But ..

vendor: 0bda, product: 1724 is NOT a known Realtek product ID

share|improve this answer
Thanks for checking it out. Perhaps the product id is too new?.. I am really at a loss. I'll email Realtek again to see if they can be of assistance. – ryanjn Nov 5 '12 at 13:35

protected by Community Mar 31 '13 at 14:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.