Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
NVidia with Optimus conflicting in Ubuntu 12.04

I just bought a new Dell XPS 14 Ultrabook which comes with a NVIDIA GeForce GT 630M. So, following some indications that I found in the documentation available online I add the bumblebee ppa and installed bumblebee and nvidia-bumblebee.

But when I tried to use the nvidia card to run something i got this error:

optirun -vv firefox
[  476.380739] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  476.381430] [INFO]Configured driver: nvidia
[  476.381498] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[  476.381513] [DEBUG]Socket closed.
[  476.381534] [ERROR]Could not connect to bumblebee daemon - is it running?

Here are some of the configuration files:


# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
# The secondary Xorg server DISPLAY number
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
# The name of the Bumbleblee server group name (GID name)
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)

## Client options. Will take effect on the next optirun executed.
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?

# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely

## Section with nvidia driver specific options, only parsed if Driver=nvidia
# Module name to load, defaults to Driver if empty or unset
# colon-separated path to the nvidia libraries
# comma-separated path of the directory containing and the
# default Xorg modules path

## Section with nouveau driver specific options, only parsed if Driver=nouveau


Section "ServerLayout"
    Identifier "Layout0"
    Option "AutoAddDevices" "false"

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "ConnectedMonitor" "DFP"

And some additional information

dpkg -l | grep nvidia

ii  bumblebee-nvidia                          3.0.1-3~quantalppa1                       amd64        nVidia Optimus support using the proprietary NVIDIA driver
ii  nvidia-current                            304.51.really.304.43-0ubuntu1             amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
rc  nvidia-current-updates                    304.51-0ubuntu1                           amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings                           304.51-0ubuntu2                           amd64        Tool for configuring the NVIDIA graphics driver

I removed the nvidia-current-updates because unity was not able to start with it installed.

By the way, I'm using the latest version of 64 bit ubuntu (12.10); and I have tried reinstalling bumblebee like 3 times.

Can you help me fixing this error? Is there other information you might need in order to help me?

Thanks in advance.

share|improve this question

marked as duplicate by Lekensteyn, Jorge Castro, Mik, devav2, Nitin Venkatesh Nov 6 '12 at 18:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

It could help you bro , it worked for me ;)

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Oyibo Nov 10 '12 at 9:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.