Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop that has USB 3.0 ports only and my portable HD doesn't work on it. I have a desktop that runs the same version of Kubuntu and same kernel version but has USB 2.0 ports, the portable drive works fine there.

Portable Drive: Western Digital My Passport 1.0 TB

Kubuntu Version: quantal 12.10

Kernel Version: 3.5.0-17-generic

When I use lsusb right after connecting the portable drive, it is read. After 10 seconds it disappears.

fdisk -l doesn't see the drive at all.

Please note that I have installed ntfs-config and blacklisted uas.

UPDATE: I plugged a USB 1.0 hub into the laptop and connected the Portable HDD through it, it worked. But the Portable HDD still doesn't work when connected to the laptop USB 3.0 port directly.

share|improve this question

1 Answer 1

Check if usb 3.0 is enabled in bios. On my computer (Dell precision) usb 3.0 was disabled by default, then only usb < 3.0 devices worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.