Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I tried to activate the newer experimental drivers and both 304 and 310 failed to even install. So I tried the regular nvidia driver 295.40 for the 20th time today (I had lag issues and was testing Nouveau vs Nvidia with dual monitor and Unity2D-3D)

Within my tty1 I tried to remove nvidia:

sudo apt-get remove nvidia-settings nvidia-current and purge too

reboot, nothing. So when lshw -c video displayed nvidia as my driver I tried

sudo rm /etc/X11/xorg.conf since I read ubuntu would "reset" the GUI conf but

reboot, nothing.

So next I tried sudo jockey-text --disable=xorg:nvidia_current And nothing has worked...

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Since then I've tried to play with jockey-text and I found out that jockey-text -l displayed that xorg:nvidia_current_updates was in use even though I couldn't install it in the 1st place.

So I disabled it but then xorg:nvidia_experimental_304 was in use and when I repeated the former process it showed that experimental_310 too was in use.

So all of the 4 drivers were in use "simultaneously" which was not ok obviously. Now that there is only one working, I have a GUI again.

I posted this because it's scary that you lose your GUI so easily, that kind of bug is way to easy to make happen since the additional drivers panel showed that NONE were in use...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.