Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When playing a 720p video file, I can hear the laptop CPU fan kick in which after a few minutes causes the video file to play back in a very choppy manner. Is it possible to stop the CPU from slowing down like this?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

On Intel based systems, you can usually run the following as root

echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

If you have more then one core, which is likely the case on a contemporary machine, repeat the command for each. You can find out the number of cores with

ls /sys/devices/system/cpu/ | grep cpu[0-9].

To get back to the default poower level, run

echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
share|improve this answer
    
I'm getting a permisson denied when I try that first command, even with sudo infront. –  oshirowanen Nov 4 '12 at 21:47
    
It seems to work with CPU Frequency Scaling Monitor, i.e. I can set it to performance, but that does not seem to make a difference. With CPU Frequency Scaling Monitor, I can also set it to 30% which really slows down the video, and I can set it to 75% which makes it smooth for a short while until the CPU fans kick in and the CPU probably slows down again even though CPU Frequency Scaling Monitor shows it at 100%. –  oshirowanen Nov 4 '12 at 21:53
    
Run sudo -i to become root, and then the commands. Run exit when done. It would be best to put all of the commands into a script and then run it with sudo. If you need to run just one command with sudo, try this: echo performance | sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor. –  mikewhatever Nov 4 '12 at 21:58
    
OK, with that, the command worked, but the video still becomes choppy when the CPU fans kick in. I think I want to somehow disable to CPU slowing down feature altogether, what's that called, disabling CPU throttling/scalling? –  oshirowanen Nov 4 '12 at 22:03
    
I've see a BIOS setting on an old computer, that scaled down the CPU at a given temperature. Could that be your case? –  mikewhatever Nov 4 '12 at 22:22
show 1 more comment

sudo su

apt-get install cpufreqd cpufrequtils gnome-applets indicator-cpufreq

and then

indicator-cpufreq &

done

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.