Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Quick background: I installed Linux Ubuntu 12.04 on a Dell Inspiron 3520 after uninstalling Windows 8. A friend suggested to do this as opposed to buying a laptop with Linux pre-installed. Everything except the wireless card works.

When I load up the laptop, I see a wireless animation as if it's trying to locate the wireless connection (for a while, then it goes blank), but no connections appear under the wireless option (under "Edit Connections" then "Wireless").

What I've tried: - Doing ndiswrapper. Failed. - Installing a few kernels for realtek. Failed.

share|improve this question

1 Answer 1

I had similar problem with RTL8187SE wireless NIC. The problem was because of the default driver r8187se is buggy. For me ndiswrapper solved the problem, but I had to blacklist the original driver (yours will be different from r8187se). After I blacklisted the original driver, and enabled ndiswrapper at the startup, everything is fine now. You can see my post here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.