Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know there are ALOT of these questions that have been asked, and solved. But I followed those I found, and for me, neither of them worked for me! ifuse won't detect my iPhone!

A few days ago I could access my iPhone just normally, but now, it doesn't work! :(

Here are some specs:

iPhone (before) :

Model : iPhone 4

iOS Version : iOS 6.0

Jailbroken? : Yes

Using stand/dock? : No

iPhone (after) :

Model : iPhone 4

iOS Version : iOS 6.0.1

Jailbroken? : No

Using stand/dock? : Yes


Model : Mac Mini (mid-2009)

Ubuntu Version : 10.04 Lucid

USB-Ports : 5

And yes, I have tested to empty all used USB's expect for the iPhone's charging cable and I have tested with the original Apple USB cable

Oh, and by the way, I tried with my sisters iPhone 3G and it worked just fine!

And still no difference!

share|improve this question

I'm having the same issue.

I have an iphone 4. 2 days ago it was using IOS 4 and I could mount the internal memory on my Ubuntu Oneiric PC. I upgraded my iphone to IOS 6 and now my PC will no longer mount my iphone. Theres no error. dmesg just has ::

[23249.171564] usb 2-1.2: new high speed USB device number 18 using ehci_hcd
[23249.386535] ipheth 2-1.2:4.2: Apple iPhone USB Ethernet device attached
[23249.436087] ADDRCONF(NETDEV_UP): eth1: link is not ready

So basically, my Ubuntu sees the phone, thinks it's an ethernet device and therefore cannot mount the disk space like it did before. Nothing I try will work. Any suggestions?

I've got the following software installed on my PC ::


I've also tried ::

sudo idevicepair unpair && idevicepair pair
share|improve this answer
Thank you for your answer. I tried the commands you listed, sadly none of them work. I've tried looking around the internet for answers, but they only work for iOS 4 <. – JomanJi Jan 17 '13 at 16:04

The problem is iOS 6. You WILL NOT be able to sync music. I know that's not what you asked, but I think it doesn't hurt to make people aware of that.

Having said that, iOS 5 made it hard to mount the iPhone on Linux, and iOS 6 made it nearly impossible. Some systems can mount, some can't, and some (like mine) mount the three file systems for five minutes and then unmount two of them. I had iTunes working on a WinXP virtual machine, but when I upgraded to iOS 6.1.3 everything stopped working altogether.

Sorry, this answer is NOT a solution, but at least it's a hint on what it would possibly be the problem.

< rant > That's why my next phone will be Android-based... < / rant >

share|improve this answer
Yeah, I thing I'll be switching to an android phone next to..., Apple just want to keep Linux out of the way, well thanx for the answer anyway – JomanJi May 2 '13 at 15:08
After I answered you, I started fiddling with it again and found out that MAYBE this is not entirely iOS 6 fault. More on that:… – Hatredman May 2 '13 at 16:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.