Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Skype on my 64bit Ubuntu 12.10 machine through the software center, but after clicking install it just keeps on saying "Installing Purchase" instead of actually downloading Skype.

After a few minutes it just stops as it times out or whatever. Anybody know what this would happen?

Thanks in advance!

share|improve this question
up vote 3 down vote accepted

What I did was go onto the Skype website and downloaded it from there. Then once I ran it, the 'Buy' button changed to 'Install'. It then carried on installing and finished succesfully

share|improve this answer
Worked perfectly! – Dean Gibson Nov 4 '12 at 19:13

There are a few issues with the Skype install on 12.10 at the moment. The powers that be are working on it. Not sure of the bug number in LP.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.