Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, the anamnesis:

Machine: Lenovo IdeaPad z570

WiFi-adapter: Intel Centrino Wireless-N 1000

OS: Ubuntu 12.04

$ uname -a
$ Linux username-Ideapad-Z570 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

WiFi-driver:

driver=iwlwifi
driverversion=3.2.0-32-generic
firmware=39.31.5.1 build 35138

Everything worked just fine until once I made a big though an unobvious mistake: I turned off my laptop's wifi-adapter via hardware switch during an active networking session. The connection went down of course, but it never come up after I turned it back on.

Network Manager applet shows an empty wireless icon, as if the adapter was turned off. No hotspots are being found.

iwlist scan returns "Failed to read scan data : Network is down" for wlan0.

dmesg | grep iwl returns

[   15.727561] iwlwifi 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   15.727616] iwlwifi 0000:03:00.0: setting latency timer to 64
[   15.727670] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[   15.727673] iwlwifi 0000:03:00.0: pci_resource_base = ffffc90000c7c000
[   15.727675] iwlwifi 0000:03:00.0: HW Revision ID = 0x0
[   15.728145] iwlwifi 0000:03:00.0: irq 44 for MSI/MSI-X
[   15.728289] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[   15.728452] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[   15.749284] iwlwifi 0000:03:00.0: device EEPROM VER=0x15d, CALIB=0x6
[   15.749289] iwlwifi 0000:03:00.0: Device SKU: 0X50
[   15.749292] iwlwifi 0000:03:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
[   15.749375] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[   15.921795] iwlwifi 0000:03:00.0: loaded firmware version 39.31.5.1 build 35138
[   15.924852] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   18.198740] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[   18.262374] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S

iwconfig returns (for wlan0):

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

As of rfkill - it shows, that no devices are blocked:

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

sudo lshw -class network returns (part of it was in Russian and translation is provided, possibly not a very precise one):

  *-network DISABLED     
       description: wireless interface
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical ID: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial №: 74:e5:0b:ce:7c:20
       capacity: 64 bits
       frequency: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-32-generic firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bg
       resources: IRQ:44 memory:f1500000-f1501fff

What I already tried and what didn't work:

  1. ifdown / ifup
  2. rfkill block all / rfkill unblock all (which is obvious, since, as I mentioned above, there are no devices blocked)
  3. rmmod iwlwifi / modprobe 11n_disable=0

I'm really, really looking forward for your help.

UPDATE: Forgot to mention: Under Win7 adapter works just fine.

UPDATE 2: Well, there's a definite progress: I managed to engage wlan0 via sudo ip link set wlan0 up. Besides, I found out, that iwlist scan has to be run by a superuser to produce meaningful result. I did so and ~finally!~ got a list of my APs! So now I'll try to connect manually by setting AP address, ESSID and WPA-key in iwconfig and report the result here back later.

But anyway: any idea what can be the problem? Something with NetworkManager perhaps? Because I had an issue with it recently after updating, which was resolved by downgrading my NetworkManager... Could this be, that I accidentally installed the latest version again?

share|improve this question
add comment

1 Answer 1

The OP solved the problem, writing:

I did it. I set up both wireless connection to a router and pppoe-channel for internet access.

I simply purged NetworkManager and added all necessary settings to /etc/network/interfaces (it was a surprise for me, that on the WPA side I only needed to define my AP's SSID and the key; defining anything else with wpa- prefix under iface wlan0 section caused various interesting errors - deauthenticating with reason=3 for intance).

I saved the interfaces and then just /etc/init.d/networking restart. PPPoE was configured by an obvious pppoeconf later.

So, I guess it must've been a NetworkManager issue... But should I reinstall it? noob snobbery mode on I don't think so. Now I'm pretty confident in setting up my networking manually, why would I need it?

I would like to thank the community sincerely for their silence, which supported me in my research and taught me a couple of lessons on self-sufficiency and google-do.

Case closed.

Originally posted in the question itself.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.