Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm very fresh to Ubuntu and I just downloaded Ubuntu 12.10 on my Lenovo x100e computer. I'm having issues with my wireless adapter. It says the adapter was turned off by a hardware switch. The issue is that my laptop has no hardware switch for wireless!

The way I used to enable/disable wireless was through Fn and F5 keys. when I tried to turn it on from the network setting, it didn't allow me. It keeps turning off straight away. If anyone has any advice or help to give I'd be very grateful.

My wireless adapter is the following: Realtek 802.11bgn

Looking forward to hearing from you and thank you so much in advance!

share|improve this question
add comment

4 Answers

The hardware switch may be referring the the Fn + F5 keyboard shortcut. Also, check your computer's bios to see if wifi is disabled or enabled.

share|improve this answer
add comment

I have the same problem on my Dell Vostro 3500. I verified the BIOS setup, wireless is enabled. Fn+F5 didn't help. I create a Ubuntu Startup Disk from my Sony Vaio; for which wireless works fine. When I boot the Vostro 3500 from that USB the Vostro's wireless work fine. I re-intalled Ubuntu on the Vostro using wireless connection.

When I reboot the Vostro on its own, the wireless option isn't available in drop down list from a the right click of network icon.

Below 'Enable Networking' was 'Enable Wireless'. Days ago I disabled 'Enable Wireless' from the drop down list and that option stopped being listed.

The 'Network' option under 'System' only shows 'Wired', and 'Network proxy'. 'Wireless' cannot be add either.

From 'Edit Connection' of that drop list I added my Wireless connection, didn't help.

The message I get is 'No proprietary drivers are in use on this system'. The identified driver listed is 'Broadcom STA wireless driver'

Under 'Licence: Proprietary' line the text reads:

This package contains Broadcom 802.11 Linux STA wireless driver for use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-based hardware.

Ubuntu 12.04 LTS, 32-bit

Hope this can help.

share|improve this answer
add comment

I found a way to enable it, very easy, I am using broadcom adapter. Go to Synaptic package manager, find precise-updates then mark bcmwl for installation, then apply and walaaaa its done.

share|improve this answer
add comment

Try an reinstall bcmwl

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.