Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just did a release upgrade from Ubuntu 12.04 to 12.10 and I noticed that even though I have the overlay-scrollbar package installed, it is not used. I have tried purging and reinstalling the package, but nothing has changed even after reboot (see screenshot).

What can I try to do to get the overlay-scrollbars working again?

overlay-scrollbar is installed

share|improve this question
Which theme are you using? – user25656 Nov 4 '12 at 15:42
Bluebird, however it's the same with any other theme that I've tried. – jeremija Nov 4 '12 at 16:07
If I'm not mistaken, Bluebird has been replaced by Greybird. If you go into /usr/share/themes/theme_name/gtk-3.0/gtk.css or /usr/share/themes/theme_name/gtk-2.0/gtkrc and search for overlay, do you see a section on overlay scrollbars? – user25656 Nov 4 '12 at 16:29
It's true that it has been replaced by Greybird, but I have used the very same theme on Xubuntu 12.04 (from git repository, which means that it hasn't been updated during this update) and the overlay scrollbars worked. I can't get any theme to show the overlay scrollbars in 12.10 so I don't think that this is theme-related. – jeremija Nov 4 '12 at 17:30
See if these links help: htorque suggests that you need liboverlay-scrollbar-0.1-0 though the version number may be different now; Erigami suggests editing gsettings. – user25656 Nov 4 '12 at 18:04
up vote 0 down vote accepted

It seems that the main reason why overlay scrollbars didn't work is because I have configured my system to boot to console first. I then use a custom .xinitrc script to start xfce:


case "$1" in
        xscreensaver -no-splash &
        exec ck-launch-session xfce4-session
        exec awesome

For some reason, when I used the command xinit xfce4 under Xubuntu 12.04 and previous versions, the overlay scrollbars appeared. However, it seems that 12.10 doesn't load this GTK module, so I had to manually execute this line declare -x GTK_MODULES="overlay-scrollbar". I ended up adding it to my .bashrc file so that I don't have to type it every time.

I got this idea from the /etc/X11/Xsession.d/81overlay-scrollbar file which says:

# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then

so I guess that this file used to be executed on each start of the X windows syst, but now it isn't used because the GTK_MODULES variable wasn't set after start.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.